Reverse Engineering Team Board

Reverse Engineering Team Board (http://www.reteam.org/board/index.php)
-   Reverse Code Engineering (http://www.reteam.org/board/forumdisplay.php?f=23)
-   -   Hasp emulation Windows 10 (http://www.reteam.org/board/showthread.php?t=7371)

amitgoyal1972 05-27-2016 08:06 AM

Hasp emulation Windows 10
 
I had successfully emulated my HASP dongle on windows XP machine and I was using it for years. I was using Multikey 18.2.2. Yesterday I had to shift to my new machine which came with Windows 10 64 bit. So I installed the same reg file with Multikey 18.1.0. But the program was not working. So I checked the device manager and it shows "SafeNet Inc. USB Key" with yellow triangle. So I checked its properties and in device status it states
"This device cannot start. (Code 10)

{Not Enough Quota}
Not enough virtual memory or paging file quota is available to complete the specified operation."

Can somebody tell me, where I am going wrong?

user1 05-27-2016 02:34 PM

sure use new Mkbus emulator, need change registry path.

amitgoyal1972 06-03-2016 11:07 PM

Thanks
 
Thanks user1,
I could find mkbus. I have installed it and it worked like a charm.
Just for my knowledge, my previous error was because of Multikey not supporting Hasp 64 bit or something else.

user1 02-28-2017 06:52 PM

Mkbus 0.18.2.6
 
http://www118.zippyshare.com/v/UlClwamC/file.html

haradhon 04-22-2017 12:53 PM

Quote:

Originally Posted by user1 (Post 39079)

can I have a live link ? this file does not exist :)

tonyweb 04-23-2017 04:01 AM

Hopefully user1 won't mind :)

Code:

Mkbus 0.18.2.6 link
http://www72.zippyshare.com/v/XVPQZ1JM/file.html

Regards,
Tony

user1 04-24-2017 03:40 AM

here new version 0.18.2.7

http://www86.zippyshare.com/v/NaqZCqvI/file.html

tonyweb 04-24-2017 06:19 AM

Thank you @user1 for the updated version :)

BfoX 04-24-2017 09:48 AM

w10 compatible?

frolito 04-24-2017 06:52 PM

Thank you @user1 for the updated version

haradhon 04-25-2017 02:58 AM

Quote:

Originally Posted by user1 (Post 39106)

this file is corrupted :(

user1 04-25-2017 03:11 AM

use winrar 5.31

jabrix 10-22-2017 06:17 PM

DUAL dongle
 
How to make dual dongle emu.

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Mkbus\ 58D74031]

adding 1 and 2 not working.
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Mkbus\ 58D740311]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Mkbus\ 58D740312]

adding A and B not working.
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Mkbus\ 58D74031A]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Mkbus\ 58D74031B]

is it HASP driver problem or Mkbus not supported.

thanks

BfoX 10-23-2017 10:12 AM

Mkbus not supported, imho.

mybstyle17 10-24-2017 03:16 AM

I have this problem also with new lectra versions.
I use mulikey 18.1.0 , the dongle is installed good (I can see it in Device Manager), but the software see only 1 dongle.
I think this is a anticrack option in lectra soft.

marcinsoo 02-23-2018 12:18 PM

Hello

I've got Sentinel HL Pro (purple), type 0EA
Run-time Package: 7.41
aksusb.sys: 3.42
akshhl.sys: 1.25
akshasp.sys: 4.25
hardlock.sys: 3.87
Firmware: 4.27
Hardware version: 7.2

Once i broken dongle and had to pay for a new one :) so i duplicated dongle in win10 64bit, i dumped HL part using RTDumperGUIv19) i have ready REG file and now:
in win xp 32bit (virtual machine) it works GREAT ! (using 32bit vusbbus.sys DriverVer=10/29/2004, 0.01.0000, sentinel (gemalto) drivers ver. 7.41). Strange thing i have an error in device manager for Sentinel HL Key : "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"


but in win 7, 8.1 and 10 64bit, using sentinel drivers 7.41, (current), test mode enabled etc., and tried different 64bit versions : MultiKey.sys DriverVer=05/16/2009, 0.18.1.0, MKbus_0.18.2.5, MKbus_0.18.2.7 DO NOT WORK :/
(off course in device manager everything seem to be OK, i got Sentinel HASP key, Sentinel HL Key and Sentinel USB key (the same as when oryginal dongle plugged)

i got a such error at the end of opening my app (app almost start...) :
"HASP Error 3: Could not log in or Hasp key is missing, status code :7
Status Desc: Container not found (haspStausContainerNotFound)." and then Login Failed, Error code=129

What am i doing wrong? do i need different drivers or what?
Please help !

BfoX 02-23-2018 02:45 PM

upload your dump/reg/soft

user1 02-26-2018 02:40 PM

no public free solutions, search a reputation RE dongle reversing services. u use public old trash, that doesn't work with latest.

cyclone 03-05-2018 03:46 PM

Actually I had face similar problem for my software too,
I Installed driver which came with software manually. Then I replaced mk bus which is suitable fof windows x64.. It is also working for windows 10.
I can try to help you to solve your problem.

BfoX 03-28-2018 06:24 AM

Quote:

Originally Posted by user1 (Post 39188)
no public free solutions.


some guys post hasp srm source for all.
rgho.st/7plXXS5MQ

user1 03-28-2018 01:09 PM

than learn and do your self. no free help for anyone as thanks of that trash dude from lavteam forum.

saifou 09-14-2018 03:32 PM

Hi all
there is no guide to modify reg from multi to mk so if some one have this guide please share

BfoX 09-15-2018 01:41 AM

if i'm right remember - you need correct the registry way in reg from multi

Tyrus 06-16-2019 02:43 PM

Quote:

Originally Posted by BfoX (Post 39206)
some guys post hasp srm source for all.
rgho.st/7plXXS5MQ

Someone inscribed me in copyrights, but these are not my sources. :confused: I know the author, and yes, a couple of functions are mine, but this is not my code.

user1 06-17-2019 09:59 AM

of course are fakes that have big names inside so scams cam sell to suckers better !
nothing new now all big names retired.

jarm 07-16-2019 08:03 AM

Which dumper works best for the superpro dongle?
I've tried a few and the dumps are slightly different with each.
SSP2mk seems to give me the most info and it seems to be larger then the rest.

All the basic info seems the same but some dumpers seem to populate a few cell with data that was 00 with other dumpers.

I haven't got the emu up and running yet so im not sure which dump will work.

Update...Got it running. the ssp2mk software dump worked...first one I tried,lol

jarm 07-17-2019 05:45 PM

Just a quick question....Do these dongle dumps contain any info that ties them to a certain customer? I don't mean Gemalto customers but the end user. If I was to buy a bunch of dongles from my software provider, would they all be the same?

user1 07-19-2019 05:08 AM

yes they do

each dongle have ID

also memory data

also they know who buy it.,

so careful spread usbtrace logs dump or even picture of 1947 Gemalto manager.

only BASIC HASP are same, they lack ID and memory, but they can be traced back no worry,

soon you try get a bad dongle reversing business you end with blacklisted dongle soft and company sue you and track you down.

jarm 07-19-2019 01:47 PM

Thank you for the reply

user1 07-24-2019 06:03 AM

well find a homeless person to buy it.

they can only give that poor soul a roof over his head and a warm meal to stop hunger.

well just a bad joke, but people that want do what you have in mind copy from other naive people dongle data or get a person like that one up do their dirty business,

just DON'T even think buy real name and SEND SOMEONE your dongle data, your terminated.

take care !

jarm 07-24-2019 04:52 PM

I was going to share my dump publicly but I don’t want any blowback for my employer. I have worked there for 20 yrs. They recently purchased the software so it been bought already, lol. I’m the only one with the dongle and it would be easy to figure out who shared it from what you’ve told me. Lol, I just wanted a copy of my software where I can use at home without the dongle. There is no cracked version of my software on the web. I have a demo version “Trialware” that I can reset but it’s an older version and lacks certain features I needed. I tried to hardcode the return values from Sx32w.dll but I ran into issues that I don’t have time to investigate. I was going to share that version but that seems in doubt now. They sure incorporated that licensing API very well and there isn’t a lot of information in the forums I can access that deals with Sentinel Licensing API reversal. It’s been a shit ton of debugging. I was lucky there was no shell and very little anti-debugging code used (they have it setup that if I try to place a breakpoint on certain functions it throws an error but only certain functions). I have to admit I’ve learned quite a bit in the last few months, it’s been fun. But I think now that I have a dongle dump and the latest version of my software, it’s time I devote myself to learning how to use it. :D

user1 07-25-2019 04:44 AM

smart safe choice.

farzad23 08-14-2019 07:05 AM

Mkbus
 
HI ALL

please someone upload Mkbus 32@64
all link is dead
thanx

eax666 09-05-2019 02:36 PM

Heh, I think I know what software it is, AT...L ?

alaska 11-20-2019 08:29 AM

USBTrace Logger to Reg
 
Is possible someone help to convert Logger to Multikey reg?

Prenumele Numele 12-03-2019 01:48 AM

I could help if dongle is hasp hl srm/sentinel hl

nodongle 12-03-2019 02:22 AM

@alaska
Simply find the converter. It on public many years.

alaska 12-09-2019 09:20 AM

USBTrace Logger to Reg
 
Hope someone can convert or help find me to find a way

alaska 12-09-2019 09:24 AM

Quote:

Originally Posted by alaska (Post 39378)
Hope someone can convert or help find me to find a way

[/quote]http://www.mediafire.com/file/olhe7g..._log_.txt/file[/quote]

nodongle 12-09-2019 11:32 PM

This dongle for IdeCAD software, in driveless mode.


All times are GMT -4. The time now is 03:17 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.