Reverse Engineering Team Board

Reverse Engineering Team Board (http://www.reteam.org/board/index.php)
-   Reverse Code Engineering (http://www.reteam.org/board/forumdisplay.php?f=23)
-   -   dmp2mkey V2.5.7.9 (http://www.reteam.org/board/showthread.php?t=4537)

Git 11-30-2011 12:46 PM

dmp2mkey V2.5.7.9
 
New version of dmp2mkey.

Changes to V2.5.7.9
Minor bug fixes and cosmetic changes.
Improvement to multithreading integrity.
OpenMP problems with Athlon CPU's fixed.
Now outputs cell 5 & 7 = 1 for MultiKey compatibility.
Compiled and optimized with latest Intel compiler V12.1.
Now 32bit and 64bit versions provided.

Now 2.5.9.1

http://hotfile.com/dl/177681349/ed94...y2591.zip.html


*** NOTE *** *** NOTE *** *** NOTE ***

dmp2mkey uses ia32 SSE2 instructions. These were introduced to Intel CPUs for Pentium 4 and AMD CPU's for Athlon 64 and Opteron in 2003. See the tables below if you have an old CPU and want to run dmp2mkey.

CPUs supporting SSE2

AMD K8-based CPUs (Athlon 64, Sempron 64, Turion 64, etc.)
AMD Phenom CPUs
Intel NetBurst-based CPUs (Pentium 4, Xeon, Celeron, Celeron D, etc.)
Intel Pentium M and Celeron M
Intel Core family (including Intel Core 2, Intel Core i5, Intel Core i7)
Intel Atom
Transmeta Efficeon
VIA C7
VIA Nano


IA-32 CPUs not supporting SSE2

AMD CPUs prior to Athlon 64, including all Socket A-based CPUs
Intel CPUs prior to Pentium 4
VIA C3
Transmeta Crusoe

Thanks to Wikipedia for the info.

Git

sverox 11-30-2011 12:54 PM

Just test 64bit on core i5 with 6 SSP dumps.
Works lighting fast. :)

kjms 11-30-2011 12:58 PM

thanks git, fast out put files > Query Cells = 24, Processing time 33.805 seconds

stuart1974 11-30-2011 01:07 PM

Thanks Git, Tested and works perfectly.

Stuart

mybstyle17 11-30-2011 04:47 PM

Thank you,working fine!!!

流星1978 12-01-2011 12:30 AM

other link please!

Yeadhiri 12-01-2011 01:00 AM

hi
 
Thanks Git

burhanuddinmna 12-01-2011 01:43 AM

Thanks Git, this works for me

adnan693 12-01-2011 02:20 AM

Thanks Git

jabil 12-01-2011 04:32 AM

Thanks KJMS for converting my dng to multikey. it works in XP and windows 7. very nice of you
jabil

Landogar 12-01-2011 05:35 AM

Thanks Git

kjms 12-01-2011 11:58 AM

GIT, in multikey sentinel example 18.2.3 and above reg should be like this
Code:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiKey\Dumps\00006CC1]
dmp2mkey2.5.7.9 out put
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiKey\Dumps\6CC10000]

this need to change....

Git 12-01-2011 12:15 PM

For multikey? has he changed it again because I specifically changed it TO that way round to accomodate MultiKey?!.

MK 0.19.1.9 manual shows it as 0000xxxx . A quick search shows every example on this forum except one as xxxx0000. I know MK changed in the past so maybe both are right depending on which version of MK you use. My own emulator uses the 0000xxxx format. Maybe I should make it a command line parameter then folk can please themselves. If I use an INI file it could have an entry for the whole of the first line path plus a template for the devid, and also entries for the name of the cell data and access code entries. That should cover most emulators.

Git

Lomex 12-01-2011 02:09 PM

Hi Git,

tried your tool, and for the first time, a converted dump does not work. I mean its not the foult of your tool. Got almost the same result with f1 nodongle.

Here the result with your tool. F1 tells me that it solved the 3 algos, but it gives me the SAME RESULT for all 3 algos, which cant be.

Code:

Dmp2Mkey V2.5.7.9  Git 29NOV2011

Number of Query Cells = 3
0x08 0x0A 0x0E

DevID = 0xXXXX
Serial = 0xXXXX
WP = 0x0000

Cell 0x08 : standard, sig=351
-***************-*******************************-***************
Cell 0x08 not solved

Cell 0x0A : standard, sig=251
-***************-*******************************-***************
Cell 0x0A not solved

Cell 0x0E : standard, sig=257
-*******************************-*******************************
Cell 0x0E not solved

Processing time  51.625 seconds

Writing MultiKey Registry file...

Any reason why your tool cant solve the needed algos. Or why F1 tool gives out the same results for all 3 algos.

Output of F1 tool:

Code:

3 algo:
08 0a 0e
 cell 08 std. algo  Cell_08 = 0100 Cell_09 = 0000 WP = 0008
 cell 0a std. algo  Cell_0a = 0100 Cell_0b = 0000 WP = 0008
 cell 0e std. algo  Cell_0e = 0100 Cell_0f = 0000 WP = 0008

Sorry cant post the dump, since it includes private data from a friend (dongle number) and I dont want that he get in trouble.

cu

Lomex

Git 12-01-2011 02:48 PM

Yeah, the problem is that they are all Standard algo which relies on the correct WP. That value of 0008 is a dummy and not correct. Any solver will fail because you cannot solve a Standard algo without the WP. That said, SafeDump will try to calculate the WP if the dongle has Standard Algos. Try to dump it with SafeDump. Your dongle will not be locked and you will probably get the WP. I believe one of the dumpers incorrectly puts an 8 there when it is told to not brute force the WP.

That "sig = xxx" that you see is a statistical analysis of the data. If the sig is greater than 700 it is an Enhanced algo, else it is a Standard algo.

If you can PM me the devid I may have a dump/regfile.


Later that same week...

@kjms - I have implemented a dmp2mkey.ini file in v2.5.8. I has the following entries :

[emulator]
path=[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiK ey\Dumps\0000xxxx]
accessname=CellType
dataname=sntMemory
cell57=1


path : this sets the full registry path where you want to store the reg file. The last part can be 0000xxxx or xxxx0000. In each case xxxx will be replaced by the DevID, also the generated file name will be 0000xxxx.reg or xxxx0000.reg.

accessname : this is the name of the access code data array. Currently CellType in multikey.

dataname : this is the name of the cell data array. Currently sntMemory in multikey.

cell57 : this is the value that will be put in the access code for cell 5 and cell7. It can be set to 1 or 3. Currently 1 in multikey and 3 in all other emulators.

This combination of values should allow dmp2mkey to generate reg files for almost any emulator with the minimum hand editing, if any. Can anybody think of any other entries for the INI file before I release it?.

Git

gus 12-02-2011 05:13 PM

thanks git nice job

Git 12-17-2011 01:04 PM

Version 2.5.9.1 now available for download.

http://hotfile.com/dl/177681349/ed94...y2591.zip.html

Code:

Changes to 2.5.9.1  17 December 2011
  Introduced INI file for flexibility
  Defined usability limit at SSE2 CPU's
  Added warning and quits if CPU does not support SSE2
  Couple of minor cosmetic changes
  dmp2mkey version noted in reg file
  Made console routines thread safe
  Added ability to save SSP file

INI file should prove useful. With correct entries it will make reg file for any VUSB based emulator. Read dmp2mkey.txt to make sure you have SSE2 CPU.

Code:

[emulator]
path=[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiKey\Dumps\0000xxxx]
accessname=CellType
dataname=sntMemory
cell57=1
ssp=0

path : this sets the full registry path where you want to store the reg file. The last part
        can be 0000xxxx or xxxx0000. In each case xxxx will be replaced in the reg file by the
        DevID, also the generated file name will be 0000xxxx.reg or xxxx0000.reg.

accessname : this is the name of the cell access code array. Currently CellType in multikey.

dataname : this is the name of the cell data array. Currently sntMemory in multikey.

cell57 : this is the value that will be put in the access code for cell 5 and cell 7.
          It can be set to 1 or 3. Currently 1 for multikey and 3 in all other emulators.
          Any other value will cause the use of cell 5 & 7 access code from the dump.

ssp  : this controls the production of a *.ssp file for old emulators, in addition to the
          reg file. The file xxxx.ssp is produced if ssp=1 and not produced if ssp=0.


Git

kjms 12-17-2011 01:19 PM

Excellent, thank you much.....

paulmarry 01-05-2012 02:56 AM

Thanks, Git

1933 04-13-2012 08:03 AM

where to find the reg file after clicking on dmp2mkey??

BfoX 04-13-2012 11:31 AM

in same folder as run dmp2mkey

Git 04-13-2012 05:01 PM

Same directory that you ran dmp2mkey.exe from.

Git

Falco67 04-16-2012 04:36 AM

Thanks Git

Qmzn 05-14-2012 02:55 PM

Git, thanks for the new version. Also, in this thread, you mentioned that:

Quote:

Originally Posted by Git
I have added an error exit at the start but I have no way to test it.

I still have a living Athlon XP system, so I tested it. is this the error exit?

Code:

OMP: Warning #72: KMP_AFFINITY: affinity only supported for Intel(R) processors.

OMP: Warning #71: KMP_AFFINITY: affinity not supported, using "none".

That's what I got with 2.5.9.1. Hope this helps.

Git 05-14-2012 05:04 PM

That's not the error I was referring to, but it's fairly clear what it's telling you.

Git

crack_dhat 10-26-2012 12:57 PM

the link is dead :(

sakanara 10-27-2012 07:44 AM

anybody pls. repost the link.

Git 10-27-2012 09:11 AM

http://hotfile.com/dl/177681349/ed94...y2591.zip.html

Git

Polaris-17 10-01-2014 05:33 PM

Link dead. Anybody can repost?

BfoX 10-01-2014 09:30 PM

Google your friend

emc11 01-11-2015 10:39 PM

What I am doing Wrong ??
 
Hello Sir,
I am using a sspro/ultrapro dongle. For Emulation purpose
I use
1. PVA 3.3 to dump dongle
2. GIT's dmp2mkey 2.3
3. Multikey 0.18.1.0

4. My dmp files PVA 3.3 & nodongle sprodumper
http://www.sendspace.com/filegroup/n...2FDVUhXoGM7rHw

Need Help for correcting the registry.

My Reg file is
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiK ey\Dumps\84FB0000]
"DongleType"=dword:00000003
"Copyright"="None"
"Created"="Sat Jan 10 23:26:48.781 2015"
"Name"="84FB Sentinel SuperPro Dump"
"Type"=dword:00000000
"CellType"=hex:\
01,01,03,03,03,03,03,03,\
03,03,03,03,03,03,00,00,\
00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,\
02,00,00,00,00,00,00,00,\
01,01,01,01,00,00,00,00
"sntMemory"=hex:\
5D,1A,FB,84,00,00,00,00,00,00,00,00,E6,D2,00,00,\
08,5B,A2,E9,14,27,DF,E4,24,AB,6A,CF,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
01,00,01,00,B2,07,08,00,9D,F3,02,00,01,E7,00,00,\
00,00,00,00,0A,00,01,00,DF,07,00,00,00,00,00,00,\
61,61,30,32,36,32,35,30,00,00,00,00,00,00,00,00


Regards

mybstyle17 01-12-2015 01:32 AM

For multikey 18.1.0 need this value
"CellType"=hex:\
01,01,03,03,03,01,03,01,\

emc11 01-12-2015 03:01 AM

Thanks for your reply. I have changed that still no success. I have recreate the reg file using 2.5.7.9 still no success. Please suggest whether i using wrong version of multikey ?? or anything wrong in my dump process ??
regards

BfoX 01-12-2015 03:48 AM

tell us your software name

woxiwox 01-12-2015 04:44 AM

possible have AES

emc11 01-12-2015 05:53 AM

any suggestions or advice ? Please guide me .

Git 01-12-2015 06:37 AM

When you change the reg file, you must stop the emulator from running, enter the .reg into thregistry again (double click it), then restart the emulator. Are you doing that?. Also, it is difficult to fix a problem if you don't tell us what is wrong. "Need Help for correcting the registry." tells us absolutely nothing about the problem.

Git

emc11 01-12-2015 09:28 AM

Respected GIT
I was working in sentinel emu 2007 in windows xp. now i want to emulate my software in windows 7 64 bit. I search this forum and trying to emulate through multikey that i can work on win 7 64 bit.

i tried previous method i mentioned and trying to solve it which can not be completed with out help of senior persons.

regards

BfoX 01-12-2015 10:09 AM

tell us version of MK you use for GemCom software

emc11 01-12-2015 10:58 AM

Any suggestion for mkey? I am using mkey 0.18.1.0


All times are GMT -4. The time now is 08:26 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.