Reverse Engineering Team Board

Reverse Engineering Team Board (http://www.reteam.org/board/index.php)
-   Reverse Code Engineering (http://www.reteam.org/board/forumdisplay.php?f=23)
-   -   Emulator: Working - Protected Software: Very Slow! (http://www.reteam.org/board/showthread.php?t=1884)

GNIREENIGNE 09-13-2009 06:28 AM

Git-

Thanks for the information. I'll definitely be more careful about it from now on.

I will do as you suggest and restart from scratch. I fear, however, that this will not fix the problem.

Well, I will continue my research and try to learn more.

If you can think of anything else, let me know. I really appreciate the help. Without experts like you, this would probably be impossible for me.

Thanks for all the help.
-G

Git 09-13-2009 06:35 AM

I can think of other things, but now is not the time to mention them. I think you must start from a known clean install. If there is still a problem we will take it from there.

Don't forget to reboot between uninstall and reinstall!

Git

GNIREENIGNE 09-13-2009 07:24 AM

Git-

Alright. I've been wanting to install WinXP on my new PC anyway.

I may not get to it this morning because I need to get some sleep. But I'll do a reformat this evening so I can start completely from scratch.

I'll let you know how it goes.

Would you recommend that I follow these same procedures?:

Emu: Multikey v18.0.3
Dumper: H5DMP
Converter: UniDmp2Reg v1.1b5 PB (vUSB Hasp HL scheme)

Thanks.
-G



UPDATE: I had a small issue with the XP install. However, things are running well now, and I am almost finished installing all of the necessary updates.

I will install the program and emulator once the updates have finished.
-G



UPDATE: Still slow.

I installed protected software & hasp drivers. Rebooted.
I created a dump (hasp.dmp & hhl_mem.dmp) with h5dmp.
I converted the hasp.dmp to reg file with UniDumpToReg v1.1b5 PB (vUSB Hasp HL scheme). I edited the reg file to run with multikey, Installed the reg file and unplugged dongle. Rebooted.
I ran install.cmd in the multikey directory. The drivers installed successfully and the devices installed successfully. Rebooted.
I opened the protected software - it opened.
I played around with the SW - it's still slow!

Where does this leave us?
Thanks.
-G

GNIREENIGNE 09-17-2009 04:05 AM

Git-

Were you able to think of anything else?

I tried to run toro monitor - to no avail. Toro could not see the dongle/software.
I ran haSploGer and was able to get the logger to see the hasp/software. Unfortunately, the text file that I saved doesn't have any keys in it (as I checked with haSploGer K-Di.exe).

If you would like to see the txt file that haSploGer generated, let me know.

I'll continue to try out other emulators.
I've been 'slowly' sifting through Russian and Chinese forums (in addition to English language sites) to try and find other solutions. -So far, to no avail.

I'll continue to keep you posted.
Thanks.
-G



UPDATE: The protected software seems to use more PCU Usage while being emulated. However, it never really exceeds 25% - which is about double the normal CPU Usage (when the actual dongle is plugged in).

I don't know if this makes any difference.

I am running:

OS (32 bit)---
Microsoft Windows XP
Professional
Version 2002
Service Pack 2

PC (Desktop)---
Gateway - Model: FX7020
Processor: AMD Phenom X4 9600(2.3GHz)
Processor Main Features: 64 bit Quad-Core Processor
Cache Per Processor: 4 x 512KB L2 Cache
Memory: 3GB DDR2 667

Thanks.
-G



UPDATE: I have searched the internet and tested a multitude of programs to no avail. I have altered my reg file many times over to no avail.

Maybe there are no emulator programs that can properly emulate this dongle/protected software without reversing the target.

Anyway, I am out of ideas. I might hire someone to try and emulate it for me with an emulator that isn't free/available to the public - but, even then, I am not too hopeful that it will work. I know there are some services that will grant you a trial license for testing purposes. I may opt for that just to see...however, I am not hopeful.

Thank you for all the help, Git. I really appreciate it.
-G

GNIREENIGNE 03-28-2021 02:01 PM

I realize that I never updated this thread. In case anyone is reading this and is experiencing a similar issue, I was able to resolve this by using a program called Time Set by sataron.

tonyweb 04-24-2021 12:25 PM

Thank you for your information.

Can you please share the tool, if you still have it? I wasn't able to find it in the wild. Maybe it's an old tool, but I'd like to put it into my collection anyway.

Thanks a lot.

Regards,
Tony


All times are GMT -4. The time now is 01:51 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.