View Single Post
  #1  
Old 09-11-2009, 06:05 PM
GNIREENIGNE GNIREENIGNE is offline
Senior Member
 
Join Date: Sep 2009
Posts: 121
Default Emulator: Working - Protected Software: Very Slow!

Hasp HL Time
OS: WinXP Pro & WinVista 32bit (emulator/protected SW runs similarly on both)
Emu: Multikey v18.0.3
Dumper: H5DMP
Converter: UniDmp2Reg v1.1b5 PB (vUSB Hasp HL scheme)

Reg file is set up to run with multikey.


Protected software is running with emu. However, the SW runs slow. Actually, it's painfully slow - not practical at all. Sometimes, I receive errors due to all of the delays. The program seems to get slower the longer I run it and mess around with it. If I close it and reopen it again, it seems to return to its original operating speed (still slow, however). If I open my task manager while running the SW, I can look at the applications tab and depending on what I am doing (with the protected software), I can see that the program sometimes toggles between 'running' and 'not responding' under the status column (in the task manager).

Additional notes: SW is also running with LMTOOLS/FlexLM. There is also another .exe file that is required to run the SW - it is a vendor specific program (vendor daemon) that acts like a server, I think. If I 'end process' (end process tree, more specifically) on this .exe file, I receive an error saying 'the desired vendor daemon is down' - and I can no longer operate my protected software.

Also, although my hasp is HASP HL Time, when I plug it in, most of the time, Hasp HL key doesn't even install. And the SW that I run performs just fine with only these two items installed:

1. Aladdin usb key
2. Aladdin hasp key
(no Aladdin hasp hl key is installed. Sometimes it will install, but my program runs with or without it -- i.e. not needed).

I have no HL_ENCRYPT/HL_DECRYPT listings in my toro log file. I was only able to get toro monitor to run once - even then, I don't know that it ran properly. (My reg file has no Q/A, E/D Tables, yet the protected SW still runs - slowly, however).

I was also able to emulate hasp and run protected SW with Chingachguk & Denger2k Emulator 0.15.4 (the protected SW runs slowly with this emulator as well).


This thread is a break away from the following thread:
Code:
http://www.reteam.org/board/showthread.php?t=1870

Thank you.

Last edited by GNIREENIGNE : 09-12-2009 at 02:36 AM.
Reply With Quote