Reverse Engineering RET Homepage RET Members Reverse Engineering Projects Reverse Engineering Papers Reversing Challenges Reverser Tools RET Re-Search Engine Reverse Engineering Forum Reverse Engineering Links

Go Back   Reverse Engineering Team Board > Reverse Engineering Board > .NET Reverse Engineering
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #21  
Old 10-07-2008, 08:05 AM
ender ender is offline
Member
 
Join Date: Oct 2008
Posts: 9
Thumbs up

Quote:
Originally Posted by LibX View Post
Anyway just released v1.3 the output will also be able to run now fixed a royal fuckup ;x
I was running v1.2 (which was the latest version at the time). I even redownloaded it and ran it against a fresh install of the app I was looking into before I posted (to make sure I'm not just talking out of my ass), but I got the same results (with not all strings being fully decoded).

I just tried v1.3 however, and whatever you changed fixed the problem, so thanks . Mind if I ask what the "royal fuckup" was?
__________________
if you build a man a fire he will be warm for a day; if you set a man on fire he will be warm for the rest of his life. :rolleyes:
Reply With Quote
  #22  
Old 10-07-2008, 09:28 AM
LibX LibX is offline
Administrator
 
Join Date: Feb 2007
Location: The Netherlands
Posts: 118
Default

Quote:
Originally Posted by ender View Post
I was running v1.2 (which was the latest version at the time). I even redownloaded it and ran it against a fresh install of the app I was looking into before I posted (to make sure I'm not just talking out of my ass), but I got the same results (with not all strings being fully decoded).

I just tried v1.3 however, and whatever you changed fixed the problem, so thanks . Mind if I ask what the "royal fuckup" was?
Well i don't know how it fixed the problem since i didnt change a single byte of code in the string decrypt function.. :S
But i forgot to fix a for loop that replaced the call to the string decrypt function with nops.
Now its working

Regards
LibX
Reply With Quote
  #23  
Old 10-10-2008, 09:13 PM
high6 high6 is offline
Member
 
Join Date: Sep 2008
Posts: 14
Default

just downloaded 1.3 and it didn't break the app this time.

Thanks
Reply With Quote
  #24  
Old 01-30-2009, 05:56 AM
ender ender is offline
Member
 
Join Date: Oct 2008
Posts: 9
Default Hey, sorry to bug you again...

Haven't really had much time to try my hand at reversing anything since the last time I posted on this board, that said, I wanted to see if I could make a proper keygen for particular app and when I ran your dotFuckScator tool it decrypted most of the strings in the program, but there were several that were most definitely not decrypted. All the sections that weren't decrypted tended to be longer sections of text. I'm not sure if this has something to do with how your string "finding" routine works, but the only other thing I noticed is that bits and pieces of the string (usually at the very beginning of the string, but in one case at the very end of the string) did get decrypted.

The particular program in question is a freeware app (the same one I had previously tried to reverse). It's called "Video Thumbnails Maker" by Scorp. I'm only mentioning the app incase you thought you might be able to debug the program or had any ideas why it might not be decrypting some string.

In particular, if you run the app through dotFuckScator, if you look in main "m" class using reflector or somesuch, and scroll about halfway down the decompiled IL, you'll see a bunch of non-decrypted strings.

Thanks once again for the great tool and also for any help you might be able to give. If you have any idea what might be the prob, hope to hear back from you.
__________________
if you build a man a fire he will be warm for a day; if you set a man on fire he will be warm for the rest of his life. :rolleyes:
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.